in reply to CPAN Module Proposal: Business::Ship
The API looks straightforward. I haven't taken the time to digest the internals, so I can't comment on that. The name is ambiguous and rather vague as is; I'd call it Business::ShippingCost, as that's its goal.
Makeshifts last the longest.