in reply to Re: Favorite Descriptive Variable Name
in thread Favorite Descriptive Variable Name
I use that all the time. Always.
My naming convention goes like this.
- @aLine = array
- $paName = pointer/reference to array
- %hCountry = hash
- $phLanguage = pointer/reference to hash
- $objLog = reference to object
The only really bad thing about this is the pointer/reference mixup, since there really are no actual pointers in Perl. This is a Bad Thing, but I'm reluctant to change on account of too much legacy code. I really should take some time and fix that though.
Now, the good thing with using this naming convention everywhere is primarily that all parameters to subs are implicitly documented when it comes to type. I find that very useful.
In Section Past Polls