http://qs1969.pair.com?node_id=129858


in reply to Fabric calculator - a better way to do it?


A few suggestions,

Most of these are rather cosmetic, but they should help readability.

Considering how many times you read from STDIN you may want to farm that part out to a subroutine. It would remove clutter from the rest of the code and should be a bit more maintainable later.

For structures like %width an array seems to make more sense than a hash. It works either way, but it's probably a good idea to try and use more appropriate tools when possible.

Also you can reduce the number of variables you have to keep track of by using a hash for multiple things. For example, your $number_of_* variables in the last section could probably be written as (using a subroutine for getting STDIN):

my %number; $number{blocks} = get_input("How many blocks are you making?"); $number{strips} = int( $total_pieces / $number_per_fabric_width_strip) +; etc...
jynx