Beefy Boxes and Bandwidth Generously Provided by pair Networks
Perl-Sensitive Sunglasses
 
PerlMonks  

Re: DBD::Oracle charsetid symbol error

by Anonymous Monk
on Aug 12, 2013 at 23:44 UTC ( #1049194=note: print w/replies, xml ) Need Help??


in reply to DBD::Oracle charsetid symbol error

...I set $ORACLE_HOME, $LD_LIBRARY_PATH appropriately...

Sure, but why isn't it working then?

:) Re^3: DBD::mysql fail install check, Re^3: how to install DBD-Oracle-1.44 on cygwin ?, DBD::Oracle install, Re^3: DBD::Oracle install, Re: DBD::Oracle install, Re^3: DBD::Oracle install, Can't use DBD::Oracle if LD_LIBRARY_PATH Not Set In Environment, Re^3: Can't use DBD::Oracle if LD_LIBRARY_PATH Not Set In Environment, Re: Can't use DBD::Oracle if LD_LIBRARY_PATH Not Set In Environment

and am stuck in the older Perl 5.8.8. I am not an admin on the system, so these are things I have little control over.

The same way you can install modules in your homedirectory you can install newest perl sh Configure -Dprefix=~/p-5.18.0/

Replies are listed 'Best First'.
Re^2: DBD::Oracle charsetid symbol error
by moof1138 (Curate) on Aug 13, 2013 at 20:18 UTC
    If I intentionally mess up LD_LIBRARY_PATH it dies differently since it can't find the lib. In this case it finds the lib but grouches about the missing 'charsetid' symbol. And I said I had little control since I know I can install another Perl install, but with this system unable to hit the outside world with a network, getting the modules set up wouldn't be pretty and when I move to deploy it would be torturous. It's working other than this one part, so unless I was certain that this was due to an old Perl I wouldn't want to go that way. I am using DBD::Proxy as a workaround for now.

      If I intentionally mess up LD_LIBRARY_PATH it dies differently since it can't find the lib.

      Well, resolving symbols kind of happens make-ing/building/compiling at linking/linker time , so if the symbol was missing before DBD/Oracle.so was created, Oracle.so wouldn't have been created

      That Oracle.so now isn't being loaded because of a missing symbol says that LD_LIBRARY_PATH is wrong

      See also Re^4: DBD::mysql fail install check (objdump -p missing symbol)

Log In?
Username:
Password:

What's my password?
Create A New User
Domain Nodelet?
Node Status?
node history
Node Type: note [id://1049194]
help
Chatterbox?
and the web crawler heard nothing...

How do I use this? | Other CB clients
Other Users?
Others chanting in the Monastery: (3)
As of 2022-09-29 08:30 GMT
Sections?
Information?
Find Nodes?
Leftovers?
    Voting Booth?
    I prefer my indexes to start at:




    Results (125 votes). Check out past polls.

    Notices?