Beefy Boxes and Bandwidth Generously Provided by pair Networks
Perl-Sensitive Sunglasses
 
PerlMonks  

Re: How to install Net::SSLeay with perlbrew on a Mac?

by stevieb (Canon)
on Jul 28, 2021 at 15:58 UTC ( #11135439=note: print w/replies, xml ) Need Help??


in reply to How to install Net::SSLeay with perlbrew on a Mac?

I'm headed to my other property later today where I've got my Mac, so I'll be glad to test things out, but I'd need to know specifically what you're afraid of breaking so I can ensure I've got as similar environment as possible.

  • Comment on Re: How to install Net::SSLeay with perlbrew on a Mac?

Replies are listed 'Best First'.
Re^2: How to install Net::SSLeay with perlbrew on a Mac?
by karlgoethebier (Abbot) on Jul 28, 2021 at 17:32 UTC

    Hi stevieb, thanks for your kind reply.

    Here is what happens when i fire up cpanm:

    And here is this bloody log:

    In the thread on crackoverflow i linked to someone made some strange suggestions how to change the environment etc. And even brian_d_foy had no idea except RTFM.

    Making changes to my beloved Perl environment just because of guessing i consider as harmful.

    Probably it is so that i miss something essential. Or I have overseen something which is totally obvious. I don't know and have no plan.

    The background is that i wanted to install FFI::Platypus which for some reasons that i don't understand yet requires Net::SSLeay.

    Thanks for any hint and advice.

    Best regards, Karl

    «The Crux of the Biscuit is the Apostrophe»

        "Are you sure...?"

        No. But please see my reply to stevieb below. Best regards, Karl

        «The Crux of the Biscuit is the Apostrophe»

      I think hippo might be right, that Net::SSLeay isn't necessary. Observe:

      steve@cecilia ~/scratch $ perl -v This is perl 5, version 34, subversion 0 (v5.34.0) built for darwin-2l +evel

      cpanm FFI::Platypus output:

      steve@cecilia ~/scratch $ cpanm FFI::Platypus --> Working on FFI::Platypus Fetching http://www.cpan.org/authors/id/P/PL/PLICEASE/FFI-Platypus-1.5 +3.tar.gz ... OK Configuring FFI-Platypus-1.53 ... OK ==> Found dependencies: FFI::CheckLib, Alien::FFI, Test2::V0 ... snipped for brevity ... Successfully installed FFI-Platypus-1.53 16 distributions installed
        "...Observe..."

        Here is what i observed:

        Karls-Mac-mini:Yaph karl$ perl -v This is perl 5, version 34, subversion 0 (v5.34.0) built for darwin-th +read-multi-2level ################# Karls-Mac-mini:Yaph karl$ cpanm FFI::Platypus --> Working on FFI::Platypus # ... snipped for brevity ... ==> Found dependencies: Net::SSLeay, IO::Socket::SSL --> Working on Net::SSLeay Fetching http://www.cpan.org/authors/id/C/CH/CHRISN/Net-SSLeay-1.90.ta +r.gz ... OK Configuring Net-SSLeay-1.90 ... N/A ! Configure failed for Net-SSLeay-1.90. See /Users/karl/.cpanm/work/16 +27544871.1168/build.log for details. --> Working on IO::Socket::SSL Fetching http://www.cpan.org/authors/id/S/SU/SULLR/IO-Socket-SSL-2.071 +.tar.gz ... OK ==> Found dependencies: Net::SSLeay ! Installing the dependencies failed: Module 'Net::SSLeay' is not inst +alled ! Bailing out the installation for IO-Socket-SSL-2.071. ! Installing the dependencies failed: Module 'Net::SSLeay' is not inst +alled, Module 'IO::Socket::SSL' is not installed ! Bailing out the installation for Alien-FFI-0.25. ! Installing the dependencies failed: Module 'Alien::FFI' is not insta +lled ! Bailing out the installation for FFI-Platypus-1.53.

        Tja. Very strange for the moment. Best regards, Karl

        «The Crux of the Biscuit is the Apostrophe»

Log In?
Username:
Password:

What's my password?
Create A New User
Domain Nodelet?
Node Status?
node history
Node Type: note [id://11135439]
help
Chatterbox?
and the web crawler heard nothing...

How do I use this? | Other CB clients
Other Users?
Others scrutinizing the Monastery: (4)
As of 2022-01-22 18:52 GMT
Sections?
Information?
Find Nodes?
Leftovers?
    Voting Booth?
    In 2022, my preferred method to securely store passwords is:












    Results (63 votes). Check out past polls.

    Notices?