Beefy Boxes and Bandwidth Generously Provided by pair Networks
Think about Loose Coupling
 
PerlMonks  

OpenSSL 1.1 support with latest version of Net::SSLeay with Perl version 5.24.

by Anonymous Monk
on Oct 26, 2021 at 07:16 UTC ( #11138048=perlquestion: print w/replies, xml ) Need Help??

Anonymous Monk has asked for the wisdom of the Perl Monks concerning the following question:

Hi Monks,

I have two questions here for Net::SSLeay module and openssl

1. Does Openssl version 1.1 support with latest version of Net::SSLeay with Perl version 5.24.

2. How to set up the environment variable OPENSSL_PREFIX which is needed in order to install Net::SSLeay.

I have tried setting up the path of the folder where openssl.exe is located but script or system seems not recognizing it,
can you please tell me what should go in the OPENSSL_PREFIX env which would cause Net::SSLeay latest version installed.

Thank you.

  • Comment on OpenSSL 1.1 support with latest version of Net::SSLeay with Perl version 5.24.

Replies are listed 'Best First'.
Re: OpenSSL 1.1 support with latest version of Net::SSLeay with Perl version 5.24.
by Corion (Pope) on Oct 26, 2021 at 07:32 UTC

    Have you looked at the README.Win32, which has step-by-step instructions for various versions of Windows? Where do things fail for you?

    I think the OPENSSL_PREFIX should be C:\foo\openssl, if openssl.exe lives in C:\foo\openssl\bin.

      Hi Corion, Thank you for the revert.

      I have set up OPENSSL_PREFIX on windows as a environment variable to "C:\app\perl_by_system\Win64\fp_lib" whereas openssl.exe resides in "C:\app\perl_by_system\Win64\fp_lib\bin".

      I also tried printing the $ENV{OPENSSL_PREFIX} in MakeFile but it seems not recognizing the value in environment variable since its empty.

      After setting path manually for openssl in Makefile.PL, it seems to be working but seems failing while gcc issue which seems libraries issue which i think should be resolved if i run it by script.

        Donít forget that you need to open a new command prompt after changing environment variables.

        Try echo %OPENSSL_PREFIX% from the command prompt to make sure the variable is set before running the makefile.

        I have set up OPENSSL_PREFIX on windows as a environment

        ;) the cmd.exe command is called "set"

Log In?
Username:
Password:

What's my password?
Create A New User
Domain Nodelet?
Node Status?
node history
Node Type: perlquestion [id://11138048]
Front-paged by Corion
help
Chatterbox?
and the web crawler heard nothing...

How do I use this? | Other CB clients
Other Users?
Others making s'mores by the fire in the courtyard of the Monastery: (2)
As of 2021-11-28 10:59 GMT
Sections?
Information?
Find Nodes?
Leftovers?
    Voting Booth?

    No recent polls found

    Notices?