Beefy Boxes and Bandwidth Generously Provided by pair Networks
Keep It Simple, Stupid
 
PerlMonks  

Re: LWP::UserAgent doesn't send my HTTP::Cookies (trace/debug)

by Anonymous Monk
on Jul 01, 2016 at 19:40 UTC ( #1167018=note: print w/replies, xml ) Need Help??


in reply to LWP::UserAgent doesn't send my HTTP::Cookies

This is how you debug "LWP" stuff, run a program like this, study the output, share the output here , omit everything that isn't LWP related

use WWW::Mechanize 1.75; my %urls = ( login => "https://$option->{hostname}/storiqone-backend/api/v1/auth/ +", list_archive => "https://$option->{hostname}/storiqone-backend/api/v +1/archive/", ); my $ua = WWW::Mechanize->new; $ua->add_handler("request_send", sub { shift->dump; return }); $ua->add_handler("response_done", sub { shift->dump; return }); $ua->post( $urls{login},, content_type => 'application/json', content => $credentials, ); print $ua->content, "\n"; $ua->post( $auth_url, content_type => 'application/json', content => $urls{list_archive}, ); print $ua->content, "\n"; __END__ ... output here ...

Log In?
Username:
Password:

What's my password?
Create A New User
Domain Nodelet?
Node Status?
node history
Node Type: note [id://1167018]
help
Chatterbox?
and the web crawler heard nothing...

How do I use this? | Other CB clients
Other Users?
Others making s'mores by the fire in the courtyard of the Monastery: (3)
As of 2022-10-01 12:13 GMT
Sections?
Information?
Find Nodes?
Leftovers?
    Voting Booth?
    I prefer my indexes to start at:




    Results (126 votes). Check out past polls.

    Notices?