Beefy Boxes and Bandwidth Generously Provided by pair Networks
Perl-Sensitive Sunglasses
 
PerlMonks  

PP Bleach Obfuscation and Win 10

by perltux (Monk)
on Feb 25, 2017 at 02:40 UTC ( [id://1182780] : perlquestion . print w/replies, xml ) Need Help??

perltux has asked for the wisdom of the Perl Monks concerning the following question:

Are there any know problems with using pp -f Bleach and then running the resulting exe on Windows 10?

My exe built on Win 7 with 'pp -g -f Bleach' runs fine on Win 7 and Win 8.1 but on Win 10 no gui of the program appears (it's a perlTk app) even though in task manager I see the program running, using up the cpu power of full core until I kill it (it's not supposed to do that).
Without -f Bleach the exe runs fine on Win 10 too.

Replies are listed 'Best First'.
Re: PP Bleach Obfuscation and Win 10
by perltux (Monk) on Feb 25, 2017 at 03:56 UTC
    Weird. I just built the exe the same way I did before (pp -g -f Bleach) again and this time it works as it should on Win 10.
    The misteries of Windows...

    I guess it's case closed then, thanks anyway for your support.
Re: PAR PP Bleach Obfuscation and Win 10
by beech (Parson) on Feb 25, 2017 at 03:15 UTC
Re: PP Bleach Obfuscation and Win 10
by stevieb (Canon) on Feb 25, 2017 at 02:54 UTC

    Code that repro's the issue would be most welcome, otherwise we have no baseline to test with.

    You can rest assured that there are people here who pay attention to Perl issues on Windows.

      I will see if I can reproduce the issue with some simple test program. I can't provide the program where I noticed this issue (otherwise there would be no need to obfuscate it anymore ;) ).