http://qs1969.pair.com?node_id=189791


in reply to Re: Naming convention for Object Variables
in thread Naming convention for Object Variables

The best thing to do is create a accessor and mutator method (or one combined method as seen often in Perl modules) for each of your properties. Users of your objects can only use these to access the property, then you're able to name them whatever you like.
Eh, no. The root of all evil is that there's just one instance variable per object, and that all classes need to stuff their properties in it somehow.

Sure, you can make accessors:

sub oogle { my $self = shift; $self -> {oogle} = shift; # Mark it as very, very, very, do not touch at all private: $self -> {_________________furble} ++; }
But if 10 levels up in the inheritance tree there is an accessor
sub habar { my $self = shift; $self -> {_________________furble} = 0; }
You are still in deep shit. No matter how many underscores you use.

Perls OO model was broken when it was designed. As I said at YAPC It sucks (to which Larry replied "I'm working on it"). Using Perl OO is no fun at all.

Luckely, there is a way to make your properties private while not losing the ability to do inheritance, or pay a costly runtime fee. Use Inside Out Object. Reverse the traditional roles of objects and properties. Let the properties be hashes, and the objects the keys:

package My::Package { my %furble; my %oogle; sub oogle { my $self = shift; $oogle {$self} = shift; $furble {$self} ++; } }
And how your inherited classes are implemented no longer matters. You'll never interfere with their properties, regardless what kind of conventions they use.

Abigail