http://qs1969.pair.com?node_id=414008

kwgagel has asked for the wisdom of the Perl Monks concerning the following question:

This is now solved.
I found docs on the internet that said to re-install perl. After doing so nothing seemed to change. But I found another one that said to use ldconfig, once I did that after the re-install GD installed just fine.

I'm having some trouble installing some modules using CPAN. I'm not sure how to tack these down to figure out what to do to fix them or for that matter where to go for help.

I am wanting to run a perl program called spamstats which will parse my log file for info. The first attempt yielded an error message that indicated I didn't have a needed module. That installed ok. Then I tried the graph utility and it needed something to but I can't install what it wants without errors.

I'm stuck, I don't know what is wrong or how to fix it.

This is what I'm seeing:

Note: I'm installing GD using "install GD"

t/use.........Can't locate GD.pm in @INC (@INC contains: /root/.cpan/build/GDGraph-1.43/blib/lib /root/.cpan/build/GDGraph-1.43/blib/arch /usr/local/lib/perl5/5.8.4/i686-linux-ld /usr/local/lib/perl5/5.8.4 /usr/local/lib/perl5/site_perl/5.8.4/i686-linux-ld /usr/local/lib/perl5/site_perl/5.8.4 /usr/local/lib/perl5/site_perl .) at /root/.cpan/build/GDGraph-1.43/blib/lib/GD/Graph.pm line 38.
BEGIN failed--compilation aborted at /root/.cpan/build/GDGraph-1.43/blib/lib/GD/Graph.pm line 38.
Compilation failed in require at t/use.t line 7. BEGIN failed--compilation aborted at t/use.t line 7. t/use.........dubious
Test returned status 2 (wstat 512, 0x200) DIED. FAILED tests 1-10
Failed 10/10 tests, 0.00% okay
Failed Test Stat Wstat Total Fail Failed List of Failed
-------------------------------------------------------------------------------
t/axestype.t 2 512 13 26 200.00% 1-13
t/use.t 2 512 10 20 200.00% 1-10
Failed 2/5 test scripts, 60.00% okay. 23/85 subtests failed, 72.94% okay. make: *** test_dynamic Error 2
/usr/bin/make test -- NOT OK
Running make install
make test had returned bad status, won't install without force

Can someone give me some direction on what to do to trace this down please.

  • Comment on Solved - Make errors installing modules from CPAN

Replies are listed 'Best First'.
Re: Make errors installing modules from CPAN
by ikegami (Patriarch) on Dec 10, 2004 at 22:42 UTC
    The module and/or a test seems the require the GD module. Have you tried installing GD first?
      That is what I'm trying to install!
        I think you're installing GD::Graph, not GD. Is that not so?