http://qs1969.pair.com?node_id=474450


in reply to Transposer

I'm tempted to suggest that "transposer" would be a better name than "demuxer", because it seems like the basic result is to transpose a matrix of values. But I realize you're also converting a list of "xSV" text-string rows into a transposed matrix -- two operations in one function.

Some purists would point out that it's better to keep the two operations distinct. (Converting a list of xSV strings into a matrix is pretty simple and applies to lots of situations, and the same is true for transposing a matrix, so why not just use the two simple functions one after the other, rather than create a relatively complex function to do both things at once?) Their argument would be that the single-job functions are easier to create, maintain and use because they are simpler in all respects -- apart from the fact that these particular two functions have already been solved, probably numerous times in different ways, in existing modules and common programming idioms.

Still, that is certainly an educational use of "map". It may not be optimal in terms of run-time or memory usage (I don't know, I haven't tried to benchmark it against any alternative, but I'll bet a faster technique can be found), but it is worth studying.