Beefy Boxes and Bandwidth Generously Provided by pair Networks
Perl Monk, Perl Meditation
 
PerlMonks  

Re^3: Experience with ActivePerl 5.10 vs. 5.8 PPM incompability

by Not_a_Number (Prior)
on Jan 06, 2008 at 19:17 UTC ( #660681=note: print w/replies, xml ) Need Help??


in reply to Re^2: Experience with ActivePerl 5.10 vs. 5.8 PPM incompability
in thread Experience with ActivePerl 5.10 vs. 5.8 PPM incompability

Hmm, I have the same problem:

ppmprofile.bat save is not supported for PPM4 yet...

Here's what I intend to try as a workaround when I upgrade to 5.10. Any suggestions for improvement welcome.

(1) At the command line, run this command:

ppm list --fields name > C:/my_modules.txt

(2) Uninstall 5.8, install 5.10 (as per the ActiveState instructions that you quote).

(3) Run the following script:

open my $fh, '<', 'C:/my_modules.txt' or die "Oops: $!\n"; while ( <$fh> ) { chomp; print "Installing $_...\n"; system ( "ppm", "install", $_ ); }

A bit of a kludge? but better than trying to do the whole thing manually???

Replies are listed 'Best First'.
Re^4: Experience with ActivePerl 5.10 vs. 5.8 PPM incompability
by ady (Deacon) on Jan 06, 2008 at 20:26 UTC
    I proceeded along the other path, as pr. the ActiveState instructions. The ppm upgrade resulted in a number of 'ordering conflicts', which I was able to resolve using the AS PPM application to reinstall the packages in question :
    C:\Perl>ppm upgrade
    ppm upgrade failed: No ordering between package Perl6-Currying-0.05 and Perl6-Currying
    ppm upgrade failed: No ordering between package Term-ReadLine-Perl-1.0302 and Term-ReadLine-Perl
    ppm upgrade failed: No ordering between package libwww-perl-5.808 and libwww-perl
    ppm upgrade failed: No ordering between package psh-1.8.1 and psh
    ppm upgrade failed: No ordering between package Digest-MD4-1.5 and Digest-MD4-1.5-r1

    These ordering conflicts are probably a result of not having cleaned up obsolete ppm versions before reinstalling new ones; I can't blame that on the AS upgrade procedure as such

    After a succesfull ppm upgrade, there were still a number of 5.8 packages missing in the 5.10 upgrade installation (eg. Win32, Win32-IE-Mechanize, GD and others). These - it seems - are not (yet) included in the AS repository, and will have to be installed from other ppm repositories in the Perl community. The problem here is, that these ppms are not (yet) 5.10 'compliant'...

    At this point in the procedure I chose to 'fall back' on a 5.8 installation (I *had* done a backup of the Perl 5.8 \site \lib, \bin and \html directories :).

    I think I'll aim at installing 5.10 in parallel with 5.8 (as recommended above by fellow reverend monks), and use 5.10 for future projects, as the needed ppm-packages get available for the latest Perl.

    Allan

Log In?
Username:
Password:

What's my password?
Create A New User
Domain Nodelet?
Node Status?
node history
Node Type: note [id://660681]
help
Chatterbox?
and the web crawler heard nothing...

How do I use this? | Other CB clients
Other Users?
Others chilling in the Monastery: (4)
As of 2022-10-07 20:12 GMT
Sections?
Information?
Find Nodes?
Leftovers?
    Voting Booth?
    My preferred way to holiday/vacation is:











    Results (30 votes). Check out past polls.

    Notices?