Beefy Boxes and Bandwidth Generously Provided by pair Networks
Perl: the Markov chain saw
 
PerlMonks  

comment on

( [id://3333]=superdoc: print w/replies, xml ) Need Help??
Well, it's the same, exact error as is in the log
---------------------------------------------- Welcome to Strawberry Perl Portable Edition! * URL - http://www.strawberryperl.com/ * see README.TXT for more info ---------------------------------------------- Perl executable: C:\Strawberry\perl\bin\perl.exe Perl version : 5.18.4 / MSWin32-x64-multi-thread c:\perlscripts>perl testprim Can't locate TMDB.pm in @INC (you may need to install the TMDB module) + (@INC con tains: C:/Strawberry/perl/site/lib C:/Strawberry/perl/vendor/lib C:/St +rawberry/p erl/lib .) at C:\perlscripts\testGetMovieName2 line 3. BEGIN failed--compilation aborted at C:\perlscripts\testGetMovieName2 +line 3. Compilation failed in require at testprim line 5. c:\perlscripts>cd c:\downloads c:\downloads>gzip -d TMDB-0.11.tar.gz 'gzip' is not recognized as an internal or external command, operable program or batch file. c:\downloads>tar xvf TMDB-0.11.tar 'tar' is not recognized as an internal or external command, operable program or batch file. c:\downloads>cpan TMDB CPAN: CPAN::SQLite loaded ok (v0.204) Database was generated on Mon, 06 Oct 2014 23:56:58 GMT Running install for module 'TMDB' CPAN: Digest::SHA loaded ok (v5.92) CPAN: Compress::Zlib loaded ok (v2.066) Checksum for C:\Strawberry\cpan\sources\authors\id\M\MI\MITHUN\TMDB-0. +11.tar.gz ok CPAN: Archive::Tar loaded ok (v2.02) CPAN: File::Temp loaded ok (v0.2304) CPAN: YAML::XS loaded ok (v0.52) CPAN: Parse::CPAN::Meta loaded ok (v1.4414) CPAN: CPAN::Meta loaded ok (v2.142690) CPAN: Module::CoreList loaded ok (v5.20140920) CPAN: Module::Build loaded ok (v0.421) Configuring M/MI/MITHUN/TMDB-0.11.tar.gz with Build.PL Checking prerequisites... requires: ! JSON::Any is not installed ! Object::Tiny is not installed ERRORS/WARNINGS FOUND IN PREREQUISITES. You may wish to install the v +ersions of the modules indicated above before proceeding with this installatio +n !! NOTE !! TMDB-v0.04 and higher uses TheMoviDB API version '/3'. This br +ings some significant differences both to the API and the interface + this modu le provides, along with updated dependencies for this distributio +n. If you like to continue to use v2.1 API, you can continue to use TMDB-0.03x [ https://metacpan.org/release/MITHUN/TMDB-0.03/ ]. Created MYMETA.yml and MYMETA.json Creating new 'Build' script for 'TMDB' version '0.11' MITHUN/TMDB-0.11.tar.gz C:\Strawberry\perl\bin\perl.exe Build.PL -- OK Running Build for M/MI/MITHUN/TMDB-0.11.tar.gz ---- Unsatisfied dependencies detected during ---- ---- MITHUN/TMDB-0.11.tar.gz ---- Object::Tiny [requires] JSON::Any [requires] Running install for module 'Object::Tiny' CPAN: LWP::UserAgent loaded ok (v6.06) CPAN: Time::HiRes loaded ok (v1.9726) Fetching with LWP: http://cpan.strawberryperl.com/authors/id/A/AD/ADAMK/Object-Tiny-1.08. +tar.gz Fetching with LWP: http://cpan.strawberryperl.com/authors/id/A/AD/ADAMK/CHECKSUMS Checksum for C:\Strawberry\cpan\sources\authors\id\A\AD\ADAMK\Object-T +iny-1.08.t ar.gz ok Configuring A/AD/ADAMK/Object-Tiny-1.08.tar.gz with Makefile.PL Checking if your kit is complete... Looks good Generating a dmake-style Makefile Writing Makefile for Object::Tiny Writing MYMETA.yml and MYMETA.json ADAMK/Object-Tiny-1.08.tar.gz C:\Strawberry\perl\bin\perl.exe Makefile.PL -- OK Running make for A/AD/ADAMK/Object-Tiny-1.08.tar.gz !!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!! +!! ERROR: Cannot copy 'lib/Object/Tiny.pm' to 'blib\lib\Object\Tiny.pm': +No such fi le or directory !!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!! +!! at -e line 1. dmake.exe: Error code 130, while making 'pm_to_blib' ADAMK/Object-Tiny-1.08.tar.gz C:\Strawberry\c\bin\dmake.exe -- NOT OK Stopping: 'install' failed for 'Object::Tiny'.
On my first go, I didn't have a folder named "perlscripts", I was running the portable shell under the directory in which portable Strawberry was installed and instead of the above error, it was showing errors in trying to extract modules/files that were supposed to be in the blib directory. And, until I created a folder name "perlscripts", there was no blib directory. And I also apparently can't manually install modules either. wtf?

In reply to Re^4: Can't install any modules by ihopnavajo
in thread Can't install any modules by ihopnavajo

Title:
Use:  <p> text here (a paragraph) </p>
and:  <code> code here </code>
to format your post; it's "PerlMonks-approved HTML":



  • Are you posting in the right place? Check out Where do I post X? to know for sure.
  • Posts may use any of the Perl Monks Approved HTML tags. Currently these include the following:
    <code> <a> <b> <big> <blockquote> <br /> <dd> <dl> <dt> <em> <font> <h1> <h2> <h3> <h4> <h5> <h6> <hr /> <i> <li> <nbsp> <ol> <p> <small> <strike> <strong> <sub> <sup> <table> <td> <th> <tr> <tt> <u> <ul>
  • Snippets of code should be wrapped in <code> tags not <pre> tags. In fact, <pre> tags should generally be avoided. If they must be used, extreme care should be taken to ensure that their contents do not have long lines (<70 chars), in order to prevent horizontal scrolling (and possible janitor intervention).
  • Want more info? How to link or How to display code and escape characters are good places to start.
Log In?
Username:
Password:

What's my password?
Create A New User
Domain Nodelet?
Chatterbox?
and the web crawler heard nothing...

How do I use this?Last hourOther CB clients
Other Users?
Others taking refuge in the Monastery: (3)
As of 2024-04-20 03:34 GMT
Sections?
Information?
Find Nodes?
Leftovers?
    Voting Booth?

    No recent polls found